Neuer Gateway aber kein Connect zu TTN und Vorstellung

Hallo meine Lieben !

Rainer hier, auch bekannt unter dem AFU Rufzeichen OE1KFR aus Gersthof. Sehr cool welch große Community ihr schon aufgezogen habt. Das Thema LoRa hat meine volle Aufmerksamkeit erlangt und hab auch schon mit den Heltec ESP32 sowohl auf 70cm in APRS als auch mit den 868MHz Varianten etwas experimentiert.
Nun hab ich einen Mikrotic LR8 AP installiert inkl. Collinear Antenne, aber ich schaff es nicht ihn mit TTN zu verbinden. Hab auch im TTN Forum gepostet, wollte aber hier auch mal nachfragen. Habs über das ETH Port mit meinem A1 Router verbunden, weil auch PoE und am A1 Router ein Portforwarding eingerichtet (Port: 1700) in Client Configuration. Am Mikrotik Router hab ich DNS eingetragen und in der Firewall UDP und TCP am eth1 in and out frei gegeben. Auf TTN hab ich das GW mit der ID vom Mikrotik generiert, aber es kommt nicht online. Mit den massiven Einstellungen am Mikrotik bin ich noch etwas überfordert zum Teil.
Wäre super Dankbar falls mit jemand helfen könnte.

Blockquote
Hier ist die Config:
feb/17/2021 10:28:49 by RouterOS 6.48.1
software id = TI2K-C6NS
model = RBwAPR-2nD
serial number =
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n channel-width=20/40mhz-XX
country=austria disabled=no distance=indoors frequency=auto installation=
outdoor mode=ap-bridge ssid=MikroTik-B8825D station-roaming=enabled
wireless-protocol=802.11
/interface list
add comment=defconf name=WAN
add comment=defconf name=LAN
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa2-psk mode=dynamic-keys
supplicant-identity=MikroTik wpa-pre-shared-key=
wpa2-pre-shared-key=
/ip pool
add name=dhcp ranges=192.168.88.10-192.168.88.254
/ip dhcp-server
add address-pool=dhcp disabled=no interface=wlan1 name=defconf
/lora servers
add address=us.mikrotik.thethings.industries down-port=1700 name=TTN-US
up-port=1700
add address=eu.mikrotik.thethings.industries down-port=1700 name=TTN-EU
up-port=1700
add address=router.eu.thethings.network down-port=1700 name=TTN-EU-open
up-port=1700
/ip neighbor discovery-settings
set discover-interface-list=LAN
/interface list member
add comment=defconf interface=wlan1 list=LAN
add comment=defconf interface=ether1 list=WAN
add list=LAN
/ip address
add address=192.168.88.1/24 comment=defconf interface=wlan1 network=
192.168.88.0
add address=10.0.0.140/24 interface=ether1 network=10.0.0.0
/ip dhcp-client
add comment=defconf interface=ether1
/ip dhcp-server network
add address=192.168.88.0/24 comment=defconf gateway=192.168.88.1
/ip dns
set allow-remote-requests=yes servers=10.0.0.138,8.8.8.8
/ip dns static
add address=192.168.88.1 comment=defconf name=router.lan
/ip firewall filter
add action=accept chain=input comment=
„defconf: accept established,related,untracked“ connection-state=
established,related,untracked
add action=drop chain=input comment=„defconf: drop invalid“ connection-state=
invalid
add action=accept chain=input comment=„defconf: accept ICMP“ protocol=icmp
add action=accept chain=input comment=
„defconf: accept to local loopback (for CAPsMAN)“ dst-address=127.0.0.1
add action=drop chain=input comment=„defconf: drop all not coming from LAN“
in-interface-list=!LAN
add action=accept chain=forward comment=„defconf: accept in ipsec policy“
ipsec-policy=in,ipsec
add action=accept chain=forward comment=„defconf: accept out ipsec policy“
ipsec-policy=out,ipsec
add action=fasttrack-connection chain=forward comment=„defconf: fasttrack“
connection-state=established,related
add action=accept chain=forward comment=
„defconf: accept established,related, untracked“ connection-state=
established,related,untracked
add action=drop chain=forward comment=„defconf: drop invalid“
connection-state=invalid
add action=drop chain=forward comment=
„defconf: drop all from WAN not DSTNATed“ connection-nat-state=!dstnat
connection-state=new in-interface-list=WAN
add action=accept chain=input in-interface=ether1 protocol=udp
add action=accept chain=output out-interface=ether1 protocol=udp
add action=accept chain=input in-interface=ether1 protocol=tcp
add action=accept chain=output out-interface=ether1 protocol=tcp
/ip firewall nat
add action=masquerade chain=srcnat comment=„defconf: masquerade“
ipsec-policy=out,none out-interface-list=WAN
/ip route
add distance=1 gateway=10.0.0.138
/lora
set 0 forward=crc-valid name=OE1KFR_GW servers=TTN-EU-open
/system clock
set time-zone-name=Europe/Vienna
/tool mac-server
set allowed-interface-list=LAN
/tool mac-server mac-winbox
set allowed-interface-list=LAN

Und hier ein Foto vom Aufbau des GW. Leider konnte ich nicht aufs Dach.

1 Like

hallo nachbar :slight_smile: wie ich sehe ist da noch die default-config im MT drinnen, zu 99%deswegen.
wir können gerne eine session machen, jitsi oder so. es sind keine forwardings oder dergleichen notwendig,
habe GENAU das gestern hinter einer bockigen fortinet eingerichtet.

der platz ist gut für das tal dort!

einfach antworten oder anschreiben, rbk@gmx.at

73
roman, OE1RBU
QTH=heuberg :slight_smile:

1 Like

Hello Nachbar :wink: !

Voll lieb von dir! Ich meld mich sehr gerne demnächst!
73 es 55 de OE1KFR

Hallo.
Versuch mal:

/lora
set 0 antenna-gain=2dB disabled=no lbt-enabled=yes servers=TTN-EU-open

Ping auf 8.8.8.8 geht nehm ich an? Sonst würde ich noch versuchen die Firewall-Regeln vorübergehend einmal zu deaktivieren.

vg wiese
OE1DAC

1 Like

Hello wiese!
Die Firewall Roules hab ich ausgeschalten, ping geht und wenn ich eine URL pinge kommt auch die DNS Auflösung. Das Portforwarding am A1 Router hab ich mal abgedreht, aber will trotzdem noch nicht. Wir machen dankenswerter Weise mit Roman eine Session am Nachmittag. Denke dann werden wir das schon zum Laufen bringen.
73
Rainer

Vielen Dank hier auch nochmals Roman für den Support heute.
Der Gateway läuft im Moment im v3 Stack. Es war aber leider nicht zu bewerkstelligen ihn im v2 zum Laufen zu bringen. Bin aber einstweilen happy, da ich meine Heltec Module ins v3 schicke und von dort per mqtt zu mir ins Node-Red hole.
73
Rainer

1 Like

Plötzlich ist der Gateway auch im v2 online…
lg
Rainer

aha, naja, die server sind ja auch nur menschen … oder so … :upside_down_face: