Bienenstockwaage mit LoRaWan connectet nicht

Liebes Forum,

ich bin Hobbyimker in Wien im Prater (KLG Ober dem Heustadlwasser 65a, 1020 Wien, Koordinaten 48.201645, 16.434986) und habe im Herbst ein Kickstarter Projekt unterstützt, wo ein Niederländisches Team eine Bienenstockwaage entwickelt hat, die Daten wie Temperatur, Gewicht etc. über LoRaWan überträgt …

Eigentlich sollte alles so konfiguriert sein, dass der Käufer (also ich) ohne Kenntnisse die Waage betreiben kann …

Leider bekomme ich aber keine Verbindung mit dem LoRaWan …
Ich kann mich übers Handy per eigener App über Bluetooth mit dem MiniComputer verbinden um einiges zu konfigurieren (Tara der Waage etc) und bei den Verbindungseinstellungen sehe ich dann folgendes:


Ich kenn mich leider überhaupt nicht aus mit LoRaWan … folgende Info stehen in der Kickstarter-Beschreibung, vielleicht hilft euch das weiter:

This custom designed printed circuit board (PCB) has an ultra low power usage. It is based on the Nordic nRF 52840 64 MHz ARM®️ CortexTM-M4. It can collect data every 15 minutes for over 1 year on 2 AAA batteries! In sleep it uses only 4,5 μA. With its 64 MB of memory the BEEP base can store two years of sensor information. Furthermore it has: over the air firmware updates (BLE), LoRa RFM95 868 MHz (EU) with uFL SMT antenna with wireless configuration, 1Wire 1-5x sensor (DS18b20), I2C screw terminals, 2 channel weight amp (HX711) screw terminals, a low power 3V regulator, unique hardware key IC, magnetic reed switch, tilt switch, buzzer, 2x AAA battery holder and, last but not least, audio ADC (92 dBA SNR) + AGC with 3.5 mm jack input with 4 pins. Size: 75x50x23mm.

Es gibt auch eine Supportseite des Hersteller-Teams, da komme ich aber auch nicht weiter …

Kann mir jemand weiterhelfen? Bin schon etwas verzweifelt …
(Ich weiß nicht, ob ich diese Frage in die richtige Kategorie eingestellt habe, wenn falsch, bitte um Entschuldigung …)

LG Peter

Servus Peter,

das ist ein tolles Projekt! Danke, dass du dich da bei uns meldest! Solche Projekte interessieren uns immer!

Ein Hinweis vorab:
du hast hier im Forum im Screenshot deine Verschlüsselungsdaten des Sensors gepostet. Vergiss’ nicht, sie dann zu ändern, sobald es (hoffentlich!) funktioniert!

Grundsätzlich würde ich erwarten, dass an der von dir genannten Position das LoRaWAN-Netzwerk funktioniert. Es sind etliche Gateways in unmittelbarer Nähe.

Hast du das Device in der TTN Console angelegt? Hat das geklappt? Siehst du bei „Data“ etwas (= Daten) ankommen?

Kannst du uns die verwendete Antenne beschreiben oder wo das genau aufgestellt ist? Sind im Nahfeld irgendwelche Hindernisse, welche die Kommunikation einschränken könnten? Vielleicht hast du ein Foto?

LgS

Hi,
In der App ist ein Button, der die Anmeldung bei TTN vornimmt.
Daten habe ich keine empfangen. Es gibt keine extra Antenne, die ist anscheinend im Gehãuse, ev auf der Platine… Vielleicht benötige ich extrem starkes LoRaWan… Wo könnte ich mit der Waage hinfahren um das zu testen? Wo ist die nãchste Antenne (zu meinem Stadort)?
LG Peter

Ja, die Antenne ist auf der Platine. Siehe Link

Die Waage steht bei mir im Kleingarten …, wenn sie mal funktioniert auf einem kleinen Hochstand, wo die Bienen drauf stehen …

Aber natürlich gibt es Häuser (auch 6. stöckig) rund herum …

1 Like

wenn ich mir die „Dokumentation“ da so anschau würd ich sagen dass da der Endnutzer LoraWan-mässig gar nix machen sollte/müsste/könnte - und device und dazugehörige App (die am Server) wohl die Betreiber managen…

vom Empfang her würd ich mir da eigentlich auch nicht so Gedanken machen, spätestens seit dem Gateway am Millenium-Tower sollte es dort sehr gut gehn.

Wie lang hast du das Ding laufen lassen? beim Test schon im Freien? evtl. braucht es ein wenig um die Datenrate (ADR) entsprechend runterzuschrauben…

Würd mich auf jeden Fall auch sehr interessieren das Teil, also wenn du es wirklich nicht selbst schaffst würd ich sehr gern mal vorbeischaun zum debuggen…

grüsse,
markus.

1 Like

kannst gerne mal vorbeischauen …ich kenn mich nicht aus und weiß nicht weiter …

nur als bookmark, weil ich’s grad gfunden hab… wird Peter nix helfen, aber könnt zum debuggen hilfreich sein…

1 Like

…der Vorteil dieser Methode wäre, dass man dann über die TTN Console sieht, ob die Waage sich verbinden kann und zB. ein Problem mit dem Datenformat oder -inhalten besteht oder die Kommunikation zB. gar nicht zustande kommt. Aktuell hätte ich verstanden sind wir da im Blindflug bzw. auf den Support/Helpdesk des Anbieters angewiesen?

@markusk: Danke, dass du deine Unterstützung angeboten hast!

LgS

Ich könnte mit der Waage auch jemanden (im Raum Wien) besuchen kommen … um den Aufwand zu minimieren …

Hast Du auch dieses Video https://youtu.be/nvfBl-h_ClE?t=92 gefunden/zu Rat gezogen?

Bei der Waage war eine Beschreibung dabei, wie man sie aktiviert etc … Das Youtube Video ist nicht mehr aktuell, da die App inzwischen eine neuere Version hat …
Aber danke für den Hinweis …

1 Like

Die Waage ist nun seit etwa 20. Juni eingeschaltet … verbindet sich aber nicht mit LoRaWAN …
:frowning:

Wäre schön, wenn mir jemand von euch helfen könnte. Ich könnte mit der Waage auch jemanden (im Raum Wien) besuchen kommen … um den Aufwand zu minimieren …

Hallo Markus,
hättest du mal Zeit dir die Waage vorzuknöpfen?
LG Peter

Auch wenn allgemeine Urlaubszeit ist … hätte jemand Zeit sich die Waage „vorzuknöpfen“? Sie funktioniert leider immer noch nicht …
LG Peter

hoi, ja, wenn du die Zeit hättest vorbei zu schaun gerne - bin bei Korneuburg daheim und hätt da auch ein laufendes Gateway mit dem wir dann gleich sehn ob/was geht wenn wir mehr oder weniger nahe sind.

ich schreib dir PN

War heute bei Markus, da hat die Waage über LoRaWan gesendet. Bei mir zu Hause geht sie leider nicht. Dh, dass ich wohl in einem LoRaWan-Funkloch bin…
Was kann man da machen? Habe einen alten Rasperry Pi… Kann man den zu einem Gateway aufmotzen? Kann mir das wer machen? Kenn mich da nicht aus…
Liebe Grüße Peter

ja, es scheint das Ding hat tatsächlich eine ziemlich miese (pcb)Antenne.

Device arbeitet mit ADR, startet mit SF12 und ist relativ schnell bis SF9 runter, weiter aber nicht obwohl wir sehr nahe beim gateway warn…

wollte nicht basteln anfangen, aber frag vielleicht mal die holländer ob es nicht doch eine möglichkeit gäb eine Antenne dranzumachen (vielleicht wär sogar stecker auf der Rückseite vom Board)

Ansonsten wäre interessant ob man es auf einen fixen Kanal einstellen kann - dann würde dir ein einfaches single-channel-gateway reichen.

Oder/und gäbs noch wo ein TTNindoor das man ihm borgen könnte @stefan @peter ? obwohl es für die aktuelle Saison wohl eh schon zu spät ist…

Servus,

ohje, das ist sehr schade, eine PCB-Antenne ist da wirklich nicht geeignet.

Ich weiß nicht, ob ein Single Channel-Gateway und das Umstellen auf einen Kanal wirklich sinnvoll sind. Damit fangen dann wir (auch noch, neben den Entwicklern) zu basteln an. Ich würde eher beim LoRaWAN-Standard bleiben…

Wie können wir helfen? Wir haben einen mobilen Gateway, den können wir mal verborgen. Der ist jedoch indoor. Lässt sich dafür auch bei Schönwetter mal neben der Waage mit USB-Akku und Handy-Tethering online bringen - damit habt ihr vmtl. mal einen ersten Erfolg und seht, dass die Station online kommt und sich mit dem Netz verbindet.

Langfristig wäre es vmtl. am besten, wenn @PNB einen LoRaWAN Gateway in der Nähe installiert. Bei den Mikrotik-Gateways ist der Aufwand ja bei ~ € 150,-. Internetverbindung vorausgesetzt.

Vielleicht sind die Betreiber aber auch bereit, eine Version/Variante mit Antennenanschluss zu machen. Das Problem werden sie in den meisten Fällen haben. Oder alle User errichten ein eigenes Netz/Gateways für diese Anwendung - das kann ich mir fast nicht vorstellen und ist auch nicht ganz die Idee von LoRaWAN bzw. TTN.

LgS

nochmal schnell gschaut

das Ding hat eh einen Antennenstecker (uFL SMT / ANT2) am Board - und wenn da nicht zumindest ein Drahtstummel am „ANT1“ angelötet ist dann fahrn die standardmässig mit gar keiner Antenne sondern mit dem reinen RFM95 … kein Wunder dass da nicht viel geht.

Wenn du es dir zutraust wär mal das einfachste und billigste einen 86mm langen Draht an ANT1 zu löten. Ich wage zu prophezeien dass das reicht, auch wenn du ihn dann einfach im Gehäuse umlegst (idealerweise sollt er im rechten Winkel zum Board stehn - aber dann bräuchts halt Loch im Gehäuse).

Falls nicht, gerne nochmal vorbeischaun, hab auch Stummelantennen mit Gehäusedurchführung, dann kann ich dir auch gern gleich den zweiten Temperatur-Fühler machen (würd sowas einfach mit Heisskleber abdichten)

grüsse,
markus.