TTGO beam mag ned

werte schwarmintelligenz …
… es ist ein wenig mühsam …
„da gibts tonnen an anleitungen und beispielcode im netz“ … hammse gesagt
„alles auf github“ … hammse gesagt
kurzum - nein, geht nicht, mag nicht, funzt nicht :-((

im detail:
zunächst einmal speziellen dank an chgerwig und stefan für die hilfestellungen und geduld! ich wollte, ich könnte erfolge verbuchen …

ich habe hier einen ttgo beam, v(ersion)07. habe einige .ino probiert, viele seiten nachgelesen, mich mit arduinoIDE geärgert etc pp. und, ja, ich habe deutlich mehr als 1 stunde oder nachmittag schon reingesteckt - ergo ist das frustlevel sehr hoch! daher starte ich meinen hilferuf mal absichtlich mit wenig info, um nicht antworten (oder nicht-antworten) zu beeinflussen: ich möchte nur den ttgo mal fürs radl verwenden und tracken. sonst nix.
soweit ich bisher gekommen bin, sendet das ding offenbar nicht. d.h. alle probleme mit keys, lmic-lib etc… kommen später :slight_smile:
arduinoIDE macht den compile und upload funktioniert. mein referenz-ttn-node sendet brav daneben und mein gateway schupft pakete, nur vom ttgo seh ich weit und breit nix.

gibt es empfehlungen welchen sketch ich verwenden soll?
vorab: ich hatte ein beispiel-ino, was bei stefan nun schlussendlich auch nciht sendet. es ist echt zum mäusemelken!

am dienstag habe ich fest vor zum treffen zu kommen, wenns schon vorher hilfe gäbe wäre super, oder eben dort vll.

danke voraus!
/roman

framecounter check abgeschalten in den device settings in der ttn-console?

1 Like

ja, ist zum testen immer abgeschalten. ist aber nicht das thema. das ding sendet nicht mal (offenbar).
ich habe hier am standort ein gateway, einen ttn-node und den ttgo. ich habe alle relevanten seiten auf der ttn-console bzw. ssh am gateway (raspi mit ic880a) offen und kann pakete vom ttn genau verfolgen.
vom ttgo sehe ich einfach nie ein paket - ich bin noch gar nicht soweit, dass ich mich über lsb/msb etc. ärgern kann :wink:

ich habe eine gute und eine schlechte/unbefriedigende info:

gut: der ttgo sendet => juhu
schlecht: ich weiss nicht genau warum :-((

habs dann nochmals mit dem DeuxVis-mapper versucht und mehr oder minder libs herumkopiert,
irgendwann meinte das ding, dass der compile durchging - und nach einschalten am fensterbankerl sehe ich plötzlich im 20s-takt pakete in der ttn-console …

öhm …

1 Like

Hallo, für den TTGO gibt es eine neue Software.
https://wiki.fablab-muenchen.de/plugins/servlet/mobile?contentId=118981529#content/view/118981529
bzw.

Ev probier mal diese und gib uns feedback.
Ich hatte noch keine Zeit zu testen.

LG,
Andreas